iframe page forum loop

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: iframe page forum loop

Re: iframe page forum loop

by axew3 » Thu Nov 29, 2018 4:12 pm

hi, yes and a new version is coming soon, that will not require to edit any file to get notification email links to point to iframe and more. There is the one about iOS devices (so now the iframe work fine everywhere)
https://www.axew3.com/w3/forum/?w3=Li92 ... Z0PTg3OA==

Re: iframe page forum loop

by kiro » Thu Nov 29, 2018 3:53 pm

i deleted all the users except mine, but the problem was that the last update rewrite the default config.php file and i forget to upload the filled config.php so the plugin was not running haha so it's solved.
i'm seeing there is a 'fix for V2 code', had been another important type of fix in the last two months? just to know
cheers

Re: iframe page forum loop

by axew3 » Wed Nov 28, 2018 8:42 am

Hi kiro!
I remembered that i had an axew3 test account into your site, so i've try to login.
What happen by results is this:
1) axew3 exist into wp side, but not into phpBB. How this happened? Did you removed?
Remember that any existent old wp user NEED to exist also in phpBB side when integration start and that when you want to delete an user, do it via WP then remove in phpBB accessing to deactivated users tab on ACP to remove those users in one click also in phpBB. If you remove an user in phpBB, manually you need to remove him also in WP, or not use him in WP side (you could use an user to login only via real phpBB url/side for example for example, even if i not know to what can be useful this, but who know).
2) the integration seem to not be active, because axew3 can login wp side, but after on real phpBB he result logged out.
And this why the iframe loop.
A logged wp user try to access the wp page with phpBB iframed: the page-forum in wp detect that the user is logged in, but it is not in phpBB, no phpBB cookie found. The result is the loop you experience for this user.

p.s: this point is important: an existent WP user NEED to exist also in phpBB because imagine that: i go into your forum side and since you leave users register in phpBB, i register an account with same email but different username in phpBB or the contrary: this NOT HAVE TO HAPPEN.
For this is mandatory to transfer all old WP users in phpBB when integration start. In the case you do not leave users register phpBB side, you not fall in the mess of mismatching usernames/emails, but by the way these users will not be able to login in WP with integration active because matching username in phpBB isn't found and a correct phpBB cookie isn't released.

iframe page forum loop

by kiro » Tue Nov 27, 2018 11:38 pm

i've not opened my website for two months because i was busy with college. i came back and i have problems, when i enter in the iframe page the page refresh automatically in a loop that never ends. i've seen that the plugin has not been updated or something, so i don't know what can be happening.
my page
regards

[TITLE EDITED]

Top