Unable to Login after Integration

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Unable to Login after Integration

Re: Unable to Login after Integration

by tjonas331 » Wed May 20, 2020 4:36 pm

I am sorry, but I tried everything what you said, but it still does not work ;(

Re: Unable to Login after Integration

by axew3 » Wed May 13, 2020 10:30 pm

Can you please remove dots on the COOKIE NAME setting?

Still do not work. Your phpBB do not correctly set the userID cookie after login, your phpBB login works using sid.
I logged in phpBB with new credentials but ...
assuming you followed instructions in my last pm, to setup phpBB the way to release cookies (and as explained on the help install page) maybe this is the reason why, STILL your phpBB do not release the correct cookie value for the userID, it remain set to 1 (guest), after a successful login.
May this is not the reason that lead your phpBB to not correctly setup login cookies, but who know? Change cookie name setting, remove dots and maybe the char - on the cookie name

Re: Unable to Login after Integration

by axew3 » Wed May 13, 2020 10:19 pm

Hello, last time i logged in with credentials you provided me to test, i reported that the cookie in your phpBB is not correctly set and it work using sid. Unfortunately i've just try to check if you resolved this problem, but using credentials you provided do not work anymore. Disabled or removed account i assume.

p.s ops, just read now pm, going to see

Re: Unable to Login after Integration

by tjonas331 » Tue May 12, 2020 5:44 pm

As said in the pm here are the screens ;)
Attachments
screen1.png
screen1.png (43.41 KiB) Viewed 457 times
screen2.png
screen2.png (17.4 KiB) Viewed 457 times

Re: Unable to Login after Integration

by tjonas331 » Sun May 10, 2020 7:07 pm

I've sent you a pm

Re: Unable to Login after Integration

by axew3 » Sun May 10, 2020 4:23 pm

It seem ok about cookies, but i can't create an account test may because i do not understand the language, it return me error when i try to reg in phpBB, could you create an account to test via wp?
Send me via pm details please.

Re: Unable to Login after Integration

by tjonas331 » Sun May 10, 2020 1:19 pm

So my Wordpres Site is available under https://www.seven-ig.de
and my PHPBB Site is available under https://www.seven-ig.de/phpBB3/
I attached a screenshot of my cookie and the plugin settings.
Maybe you can see a mistake.
Attachments
W3ALL Settings.png
W3ALL Settings.png (116.18 KiB) Viewed 346 times
Cookie Settings.png
Cookie Settings.png (40.25 KiB) Viewed 346 times

Re: Unable to Login after Integration

by axew3 » Sun May 10, 2020 8:17 am

phpBB do not save cookies, and using just session, i assume because the cookie setting into your phpBB is wrong?
OR did you setup the option in phpBB ACP
Allow Remember Me option need to be set to YES and set remember me time maybe to 365 gg.
One of two above mentioned, should be the problem.
Which is the url?
if the url of your site is
mydomain.com
the cookie domain setting need to be .mydomain.com
if it is mysite.co.uk will be .mysite.co.uk
while the cookie path setting need to be a single slash /
if you change these settings, then logout and clean cookies by clicking into Delete cookies link, on the right link on phpBB bottom pages. Re-login

Re: Unable to Login after Integration

by tjonas331 » Sat May 09, 2020 6:14 pm

I used /wp-admin to reset password (sometimes it does not say password wrong, I get just redirected home the startpage without beeing logged in)

What is also strange, that now my forum is not saving my login and I always have to login again.
Do you know a solution?

Re: Unable to Login after Integration

by tjonas331 » Sat May 09, 2020 5:57 pm

So I created a new user on both sites with the same password, email and username.
The user is on both sites logged in as an admin.
When I activate the plugin I get logged out.
But I am only able to log into phpBB.
In wordpress I am unable to login.

P.S.
I was able to deactivate the plugin

Top