Crayon Syntax Highlighter: WordPress 5.4> Gutenberg - Php 7.4 > compatible

User avatar
axew3
w3all User
w3all User
Posts: 1971
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Crayon Syntax Highlighter: WordPress 5.4> Gutenberg - Php 7.4 > compatible

Post by axew3 »

Crayon Syntax Highlighter plugin seem to be not anymore maintained, but i find out more comfortable, for example in this site, where code blocks display in WordPress pages, to maintain this plugin compatible along the time, and do not switch to something else. Here in attach there is the
Crayon Syntax Highlighter updated to work fine on WordPress, Gutenberg, and i assume into any Php version


Download on bottom of this post the patched Crayon Syntax Highlighter plugin and rewrite old plugin's files in:
/wp-content/plugins/crayon-syntax-highlighter

Working fine on last WordPress under Php 7.4.7
Download here:
It present more and more bugs, i'm sorry, it will be useful just to follow display old inserted code contents and not to add new code snippets. I have no time to reverse all things that seem to be quite complicated and require too much time. Sorry again
Attachments
crayon-syntax-highlighter.zip
(2.07 MiB) Downloaded 46 times