About permalinks and WP_w3all integration

WP_w3all phpBB code with others external plugins
User avatar
axew3
w3all User
w3all User
Posts: 2227
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

About permalinks and WP_w3all integration

Post by axew3 »

Note that any configuration of WordPress permalinks is allowed to be used with WP_w3all plugin, except the Plain option.
The Plain option do not contain the name of the page on permalink URL, so the created forum page will not be found by WordPress when called, if this is the permalink option active.
If you use the custom option for permalink, this need to contain the page name.

WP_w3all can work also with plain permalink option, but in some server configuration, as it is coded at moment of this post, it need to be adjusted in case or page forum when called will be NOT found.

CORRECT [EDITED]:

OR to resolve, you can use plain permalink, but for the specific forum page, you'll set manually the permalink name when you create or edit the page for the embedded forum.

Reflykt

Re: About permalinks and WP_w3all integration

Post by Reflykt »

So, how would I setup the forum on the wordpress page and how to get it shown?

User avatar
axew3
w3all User
w3all User
Posts: 2227
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: About permalinks and WP_w3all integration

Post by axew3 »

So this i maybe not the right topic to do this answer. This topic is about permalinks, and you ask about this instead:
https://www.axew3.com/w3/2016/02/embed- ... esponsive/

lindalong
User w
User w
Posts: 7
Joined: Mon Sep 18, 2017 6:00 pm

Re: About permalinks and WP_w3all integration

Post by lindalong »

I am having a problem with permalinks. I have permalinkis set to postname. But the links to the urls are not working. No matter what link, it just takes us to the board index
The links are odd too:
http://ffrcnation.com/board/?w3=./viewforum.php?f=25

Not sure what the ?w3=./ part is?
If I put in the link it just gives me the forum index

I tried it without ?w3=./and get page not found.

Any help here would be appreciated.
Thanks
Linda

User avatar
axew3
w3all User
w3all User
Posts: 2227
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: About permalinks and WP_w3all integration

Post by axew3 »

Hi! Did you updated only the page forum, but not the overall_footer.html code?
wordpress-phpbb-template-embed-v2
also, if yes, did you rebuilt phpBB template?

p.s check well new code requirements that is little different from previous code. V3 complete version is on the way.

lindalong
User w
User w
Posts: 7
Joined: Mon Sep 18, 2017 6:00 pm

Re: About permalinks and WP_w3all integration

Post by lindalong »

That got me closer but now the URL links look like this:
http://ffrcnation.com/board/?w3=Li92aWV ... MmdD0xMzE0

They do work though. But they are not the same links as you see when you hover over the title.

I updated overall_footer.html and ran the template refresh through the admin.

I also updated page-forum.php in /public_html/wp-content/plugins/wp-w3all-phpbb-integration/addons

What did I miss?
Thanks
Linda

User avatar
axew3
w3all User
w3all User
Posts: 2227
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: About permalinks and WP_w3all integration

Post by axew3 »

I cheched that your install is working now.
Cleanup cache maybe on phpBB ACP main page AND
activate the very last option on plugin admin page, to points widgets urls to the wp page with the iframed phpBB.

Post Reply