Login Loop

Tolodine
Posts: 3
Joined: Wed Oct 23, 2019 2:18 am

Login Loop

Post by Tolodine »

I have read all of the instructions provided before activating the plugin but as soon as I put in the absolute path to the phpbb config.php file, I get into a login loop. What I mean is I can log into the site but then it redirects me to back to the main page of my site and logs me right back out. Does the same thing when I go to my wp-admin page. I try to log in and it redirects me back to my main page and logs me right back out. I have a user with the same username and email and even the same password on the phpbb forums as the one I am installing the plugin with. Any suggestions would be helpful.

User avatar
axew3
w3all User
w3all User
Posts: 1842
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login Loop

Post by axew3 »

CLEAN UP ALL COOKIES on browser if not already done, or click into phpBB bottom link and delete all board cookie.
Then try to re-login.
Still in trouble?

Tolodine
Posts: 3
Joined: Wed Oct 23, 2019 2:18 am

Re: Login Loop

Post by Tolodine »

Unfortunately not. I have playing with it for about 2 days trying different things. As I said, I followed all of the instructions. Only thing I can think of is it might be Jetpack doing it but not really sure. Luckily I know how to modify the tables and break the plugin so I can get back into my admin panel.

User avatar
axew3
w3all User
w3all User
Posts: 1842
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login Loop

Post by axew3 »

happen for several reasons, but the plugin work fine into sites with any plugin installed i can assure, even if i not tested jetpack from long time...
did you setup as https both phpBB and wp, if on https, and http if http?
Is the site online?

User avatar
axew3
w3all User
w3all User
Posts: 1842
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login Loop

Post by axew3 »

read post above and ...
p.s about login to your wp-admin:
READ NO PANIC INSTRUCTIONS:
viewtopic.php?f=13&t=679

Tolodine
Posts: 3
Joined: Wed Oct 23, 2019 2:18 am

Re: Login Loop

Post by Tolodine »

Both forums and wordpress are https. The forums are just in a sub directory off the root. Wordpress is in the root. Only difference in the 2 is that phpbb uses a different database from wordpress. After playing with it for a few days I kind of gave up on it. I wish I could get it to work.

User avatar
axew3
w3all User
w3all User
Posts: 1842
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login Loop

Post by axew3 »

the fact that the database is different, do not change nothing, your problem is, a cookie problem. Substantially any problem with this plugin about logins, are +- ever cookie problems. Here some common solutions you can follow check to be up and running


Did you setup cookie in phpBB to be available over all the domain?

On ACP, cookie setting:
You need to setup as localhost if on localhost and as
.mydomain.com
if online on some site. Be careful on setting up these settings.
If changed, logout and CLEAN COOKIES on browser (may click into bottom phpBB link "Delete cookie" (that will delete all board's cookies))

Check also that this setting in ACP, on
Server configuration -> Security settings
the setting -> Allow "Remember Me" logins:
set it as Yes
and
Validate browser: set to YES

We should have cover + or - all common possibilities here, then i hope you'll be up and running soon!

xray
User ww
User ww
Posts: 34
Joined: Mon Dec 24, 2018 9:48 pm

Re: Login Loop

Post by xray »

Odd, after new update site went into a redirect loop after logging in on phpbb forums. I checked out the two patch files and loaded them as instructed. I had not changed anything within cookies and the remember me has been activated in the ACP...

I then checked the login and noticed the remember box was not checked. I checked this box and logged in again without the loop. I can't remember, but isn't there a section to make sure that box is checked by default so that user registering or logging in for the first time won't get stuck in a loop?

User avatar
axew3
w3all User
w3all User
Posts: 1842
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login Loop

Post by axew3 »

the not remember me query was containing a bug (and also the remember me):
have you updated both files at date of this post or before?

Thu Dec 05, 2019 9:23 pm

let know

xray
User ww
User ww
Posts: 34
Joined: Mon Dec 24, 2018 9:48 pm

Re: Login Loop

Post by xray »

I updated both files. I ended up installing an extension to have the box checked by default

Post Reply