Login issues

DesmoGiec
Posts: 1
Joined: Tue Feb 11, 2020 5:47 am

Login issues

Post by DesmoGiec »

Hello there,
I have a problem when trying to log in.
Here what I saw.
Perform login through WP is ok. I result logged in wp AND also in phpbb.
Doing the login through phpbb only works for phpbb, in wp I'm not logged in.
htaccess already setup for redirecting http to https, wp and phpbb only works in https.
acp cookie settings are enabled on secured.
What can i check?
thanks

User avatar
axew3
w3all User
w3all User
Posts: 1889
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login issues

Post by axew3 »

Cookie setting in phpBB ACP -> server configuration -> cookie settings. It need to be single slash:
/
save setting.
It seem a phpBB cookie problem, not recognized by wordpress, because not released as valid overall the domain.

Also into phpBB Security Setting, setup these settings:

Allow "Remember Me" logins: YES
"Remember Me" login key expiration length (in days): 365
Validate Browser: YES

Now logout the user, clean cookie board (may click into the bottom/right Delete cookies link, available on phpBB frontend). Re-login

User avatar
axew3
w3all User
w3all User
Posts: 1889
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login issues

Post by axew3 »

Ah! And do not forget the cookie domain value:
it need to be localhost or empty value if on localhost

and need to be:
.axew3.com
if as example your board installed at www.axew3.com or subdomain.axew3.com
setup this value with the domain name, with a preceding dot:
.axew3.com

https values you say already setup. So you should be up and running.

Logout when saved these changes, clean up cookies on browser as said above, then re-login.

Guest

Re: Login issues

Post by Guest »

Hey, thanks for the reply.
It was all already set up correctly.
Now it works, and I don't know why.
here what i've done.
I changed the cookie domain from .domain.com to nothing and saved, from acp.
Cleared all cookies and tried.
Login from phpbb worked also on wordpress.
BUT, can't login from wordpress anymore, getting redirected to homepage without credentials.
Then...
I changed again cookie domain in acp, reverting to .domain.com, saved..
Cleared cookies.
Et voila, all started to work perfectly :shock:
So, it is all like it was before, but now it works. :lol:

Meh, all's well that ends well :mrgreen:

User avatar
axew3
w3all User
w3all User
Posts: 1889
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login issues

Post by axew3 »

Et voila, all started to work perfectly
So, it is all like it was before, but now it works.
Cookie problems are all about loops into template integration or issues like you experienced.
This plugin is cookie based. It's ok, since WP do not allow login users with cookie disabled on browser (almost by default behavior)
Old phpBB cookies, may released before to change the cookie domain setting, still affect, so until not cleaned up by clicking into delete cookie board, or due to an explicit logout/login after these settings changed, normally lead to this problem.

There are several issues about cookies that lead to same problems: we'll try to cover all possibilities on a fast and clean How To, may into the help install page (that already contain it, even if may long and badly explained).
And also to resolve via code all what possibly is still wrong, into client browser when integration start

Post Reply