Can't get the embedded phpbb3 forum to work

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Can't get the embedded phpbb3 forum to work

Post by Dysphoria »

Oh my, that last thing did. I forget to set recompile stale template settings to yes. It works now. Thank you so much!

User avatar
axew3
w3all User
w3all User
Posts: 1971
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Can't get the embedded phpbb3 forum to work

Post by axew3 »

I see the login widget of the plugin, need care about to output almost, a decent layout.
Will be done on next release, in the while you can adjust with quite easy, in case, the file output, editing, into plugin /views/ folder, the file:
wp_w3all_login_form.php
Or just use some other plugin login form in the while, or the default wordpress login.

I deserve holiness today ...

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Can't get the embedded phpbb3 forum to work

Post by Dysphoria »

I don't want to be rude or anything, but I don't really understand what you mean, haha.

You definitely deserve some holiness. Thanks for having patience with me.

User avatar
axew3
w3all User
w3all User
Posts: 1971
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Can't get the embedded phpbb3 forum to work

Post by axew3 »

Dysphoria wrote:
Fri Feb 14, 2020 1:01 pm
I don't want to be rude or anything, but I don't really understand what you mean, haha.

You definitely deserve some holiness. Thanks for having patience with me.
Ehi! it was just a joke about the fact it required a little more to be up and running!
Follow with questions whenever it is necessary, or if you can't find out elsewhere!
Cheers! alessio

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Can't get the embedded phpbb3 forum to work

Post by Dysphoria »

Hey, I'm back again. Ever since I've got my ssl certificate and forced https on all webpages, my forum has been acting strange. Everytime I want to log into ACP I get redirected to my front page on wordpress or another page saying they couldn't find the web adresse. I've tried to uninstall everything, even de forum. I installed everything back again, but there is still this issue. I think it has something to do when I tried editing everything to https, but I don't know what to do. I can't edit anything on my forum, because I can't get into ACP anymore. I edited the codes to https, so it's not like I forgot that.

User avatar
axew3
w3all User
w3all User
Posts: 1971
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Can't get the embedded phpbb3 forum to work

Post by axew3 »

have you try to disable javascript on browser, and access the phpBB (using https://...) with direct url, then login, then login ACP, and change settings? Also may clean cookies!

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Can't get the embedded phpbb3 forum to work

Post by Dysphoria »

I've installed it again, I think I know what was wrong. I probably forgot something, again. I'm going to test it and I'll let you know.

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Can't get the embedded phpbb3 forum to work

Post by Dysphoria »

I tried to install everything back as I did before, but now I get this error when I try to go to my board:
HTTP ERROR 500

So I can't do anything anymore inside acp.

And when I try to upload my precious files from my backup folder, it's still broken.

User avatar
axew3
w3all User
w3all User
Posts: 1971
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Can't get the embedded phpbb3 forum to work

Post by axew3 »

You say you reinstalled the board, and now you get this, but
Error 500 mean many things: what about your (root phpBB) .htaccess file?
Is the default one?
Did you uploaded in the while, and overwrite some phpBB file with wrong chmod premission?
Have you try to execute the chmod with right permissions to all files and directories, if you uploaded again some files?

Post Reply