Last topic widget + registration redirect to iframe

User avatar
axew3
w3all User
w3all User
Posts: 1884
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Last topic widget + registration redirect to iframe

Post by axew3 »

can you try to substitute:

/wp-content/plugins/wp-w3all-phpbb-integration/views/phpbb_last_topics.php

with this one in attach? May a global var missed/not assigned, cause that the url built in wrong way ... but it is strange
phpbb_last_topics.zip
(2.26 KiB) Downloaded 10 times

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Last topic widget + registration redirect to iframe

Post by Dysphoria »

I'll try it tomorrow and I'll let you know.

User avatar
axew3
w3all User
w3all User
Posts: 1884
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Last topic widget + registration redirect to iframe

Post by axew3 »

Dysphoria wrote:
Thu Feb 20, 2020 10:12 pm
I'll try it tomorrow and I'll let you know.
yeah! take your time! :D

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Last topic widget + registration redirect to iframe

Post by Dysphoria »

It did nothing. :)

Could it be it has something to do with .htaccess? 'Cause suddenly a code I added earlier this week was gone.

Code: Select all

# BEGIN WordPress
# De richtlijnen (regels) tussen `BEGIN WordPress` and `END WordPress` worden
# dynamisch aangemaakt en zouden enkel aangepast mogen worden via WordPress filters.
# Elke wijziging aan deze richtlijnen tussen deze markeringen worden overschreven.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

##------Forceer HTTPS verbinding geheel domein------##
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
##

User avatar
axew3
w3all User
w3all User
Posts: 1884
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Last topic widget + registration redirect to iframe

Post by axew3 »

Have you try to remove this from the htaccess, but it seem correct:

Code: Select all

##------Forceer HTTPS verbinding geheel domein------##
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
##
what happen?

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Last topic widget + registration redirect to iframe

Post by Dysphoria »

Well, that was the code that was suddenly removed. No idea why because I hadn't opened it after I put that code there the first time.

When I remove that, the http:// adress becomes available again, which results in not being able to login.

User avatar
axew3
w3all User
w3all User
Posts: 1884
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Last topic widget + registration redirect to iframe

Post by axew3 »

Ok, a moment, as ever little confused (when you have not all under hands it is easy) ...

I see that the url output on widget, is from the start wrong, so there is something that lead to this somewhere.
Just to not loose the vicious, can you try to test this then?
phpbb_last_topics_2.zip
(2.25 KiB) Downloaded 27 times
WordPress Address (URL) and Site Address (URL)
Into wordpress, under Settings -> General, what are URLs of the site you have setup into?

[EDITED]

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Last topic widget + registration redirect to iframe

Post by Dysphoria »

I have to remove the '2' in the name, right? haha Nvm that lol.

Both are this:

Code: Select all

https://talkatastic.be

Dysphoria
User ww
User ww
Posts: 43
Joined: Tue Feb 11, 2020 8:45 am

Re: Last topic widget + registration redirect to iframe

Post by Dysphoria »

Well, it's still not doing what it's supposed to do, but now it leads me to the same page as when I click on register. So there is a change in the url's.

Code: Select all

https://talkatastic.be/forum/?forum_id=7&topic_id=57&post_id=201#p201
Omg, wait. I'm stupid. guests can't read topics on my forum, I forgot. Wow, that was really stupid. It proably works now. I'm gonna test it out.

[EDIT]: Yep, the above works now. Gosh, that was stupid haha. But okay, there probably still was something wrong with the last topic widget, hence the weird url.

But okay, now the problem is that people don't get redirected to the register page or to the right page when they click on 'I forgot password'.

User avatar
axew3
w3all User
w3all User
Posts: 1884
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Last topic widget + registration redirect to iframe

Post by axew3 »

No look, it is not easy understand these things ...

Anyway, it is still not ok because links return:

Code: Select all

https://talkatastic.be/index.php/index.php/forum/?mode=sendpassword
or

Code: Select all

https://talkatastic.be/index.php/index.php/forum/?forum_id=6&topic_id=54&post_id=203#p203
there is something into your wordpress configuration, that add double index.php into urls?

Some setting into wp that lead to this? Or plugin code (strange) into some configuration ...
I will try to get it out on mind what it can be

Post Reply