WooCommerce transactions are failing with new update

openroadsite
User w
User w
Posts: 14
Joined: Wed Sep 23, 2020 1:53 pm

WooCommerce transactions are failing with new update

Post by openroadsite »

Hello,

I reported last week about an issue where now within WooCommerce when a user tries to submit their payment information I end up with the following error message:

"SYNTAXERROR: UNEXPECTED TOKEN < IN JSON AT POSITION 0"

This is something that I encountered with the 2.5.5 update and now it continues with the 2.5.6 version.

While running these tests I tried to view the logs but unfortunately don't see anything coming up on the Wordpress or cPanel logs.

In a previous thread there was a request for settings. I took a screenshot and have shared it here. Let me know if any additional information is needed:

Image

User avatar
axew3
w3all User
w3all User
Posts: 2497
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: WooCommerce transactions are failing with new update

Post by axew3 »

Thank for your report. Ok, unique way, seem remain to install this:
https://woocommerce.com/document/payments/testing/
and go to check what it happen... let see, i'll be in reply soon.

If there is a problem, at this point, for what i understand and your reports, it come out behind the scene, seem when an ajax call fire: at this time, often, errors are impossible to views. The unique way, is to place a logger, just a line of code that write data into a file when ajax execute, so that will be possible to see what happen during this request.

Going to see if we get lucky
https://www.youtube.com/watch?v=5NV6Rdv1a3I

User avatar
axew3
w3all User
w3all User
Posts: 2497
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: WooCommerce transactions are failing with new update

Post by axew3 »

Reproduced, and resolved the issue, thank for your report again.

Code: Select all

= 2.5.8 =
*Release Date - 22 Feb, 2022*

* Fix: definitively fix the important option "Disable existence check of the email in phpBB before it is updated in WordPress" that was setting at contrary the resulting effect enabled/disabled
* Fix: fix wp_w3all.php and admin/config.php to correctly manage the last added phpbb_iframe_short_pages shortcode option
2.5.8 has been released.
Please update immediately and
set to YES the option
"Disable existence check of the email in phpBB before it is updated in WordPress"

I tested and reproduced the issue on woocommerce, exactly the same as you, so i will test after why it come out if this option (again misleading setting on 2.5.7, now fixed!) is set as (actually) no.

Set it, after update to 2.5.8, to YES and all will be fine

User avatar
axew3
w3all User
w3all User
Posts: 2497
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: WooCommerce transactions are failing with new update

Post by axew3 »

Last commit on 2.5.8, seconds ago, set as default to YES this option
and the inline hint now say this:
disable_email_check_option.png
disable_email_check_option.png (46.43 KiB) Viewed 171 times

i am afraid that this option misunderstanding caused (i'm sure) many problems to many.

Ps
So since 2.5.9 this option (if already updated before this change, to 2.5.8) become disabled by default.
As it is more obvious that it need to be.

[EDITED]

openroadsite
User w
User w
Posts: 14
Joined: Wed Sep 23, 2020 1:53 pm

Re: WooCommerce transactions are failing with new update

Post by openroadsite »

axew3 wrote:
Tue Feb 22, 2022 12:18 pm
Reproduced, and resolved the issue, thank for your report again.

Code: Select all

= 2.5.8 =
*Release Date - 22 Feb, 2022*

* Fix: definitively fix the important option "Disable existence check of the email in phpBB before it is updated in WordPress" that was setting at contrary the resulting effect enabled/disabled
* Fix: fix wp_w3all.php and admin/config.php to correctly manage the last added phpbb_iframe_short_pages shortcode option
2.5.8 has been released.
Please update immediately and
set to YES the option
"Disable existence check of the email in phpBB before it is updated in WordPress"

I tested and reproduced the issue on woocommerce, exactly the same as you, so i will test after why it come out if this option (again misleading setting on 2.5.7, now fixed!) is set as (actually) no.

Set it, after update to 2.5.8, to YES and all will be fine
It works again!!!

Thank you so much for the lightning-fast response, it is truly appreciated!

Post Reply