Login problems

jls
Posts: 4
Joined: Wed Nov 23, 2022 8:50 pm

Login problems

Post by jls »

I have installed the WordPress w3all phpBB integration plugin in WP but not the phpBB extension in phpBB.

My administrator login works on both WP and phpBB, but logging into one does not log me into the other.

When I register a new user in WP, the user is correctly added to phpBB. However, the new user login will not work for WP, but I can use it to log directly into phpBB. Resetting the password while the WP w3all phpBB integration plugin is activated does not fix the problem. If I deactivate the plugin, some of the WP passwords will work without resetting and the others will work if I reset them. If I reactivate the plugin, all WP logins except for the administrator stop working, but the same passwords work for direct login to phpBB.

WP: 6.1.1
phpBB: 3.3.8
PHP: 7.4.33

Suggestions to fix this?

John S.
User avatar
axew3
w3all User
w3all User
Posts: 2716
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login problems

Post by axew3 »

Code: Select all

My administrator login works on both WP and phpBB, but logging into one does not log me into the other
Admin UID1 in WP and UID2 in phpBB are not linked.
May you refer to this?

About logins: instead of passwords, which happen because the hash the plugin use is the one of phpBB in WP for users, so yes when integration disabled may some user, if pass re-hashed, need to reset the pass, but are you sure that the cookie setting of phpBB is ok, and you followed all steps about phpBB side?
https://www.axew3.com/w3/wordpress-phpb ... n-install/
User avatar
axew3
w3all User
w3all User
Posts: 2716
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login problems

Post by axew3 »

and ... are you sure that the user you use to test have an email that is not shared with someone else in phpBB (two users in phpBB using same email)?
... just to mention what come in mind on fly...
jls
Posts: 4
Joined: Wed Nov 23, 2022 8:50 pm

Re: Login problems

Post by jls »

The problem was the cookie domain setting.
Everything seems to be working now.
Thank you!
John
thunder86
Posts: 1
Joined: Sat Mar 25, 2023 10:11 am

Re: Login problems

Post by thunder86 »

Hey I’m coming back to this topic! I have exactly the same issue. How do you fixed it?
User avatar
axew3
w3all User
w3all User
Posts: 2716
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Login problems

Post by axew3 »

Hello, i put my own one on fly about sites behind cloudflare:
it happen that sometime on phpBB behind cloudflare, the session cookie of it keep reloading and reloading, each time the page load: the old is suppressed and a new one released.

I do not tested if it happen only when phpBB is loaded as iframe, because i was installing on fly an iframe mode into a site, but to make it work cookies, or cloudflare were disabled or some feature of it changed to avoid this behavior (you can see on browser's console, if it is the case, that cookies values keeps changing each time a phpBB page load).


Assuming that your phpBB cookie setting is correct (as explained into the help install page) see phpBB side install hints https://www.axew3.com/w3/wordpress-phpb ... n-install/
this could be the problem also. ALso check that settings mentioned on the install steps page about phpBB,have been all set as suggested
Post Reply