Recaptcha stopped working

jls
Posts: 4
Joined: Wed Nov 23, 2022 8:50 pm

Recaptcha stopped working

Post by jls »

I installed the Advanced Google Recaptcha plugin from WPConcern before installing the WordPress w3all phpBB Integration plugin. I set the recaptcha to appear on the registration and lost password forms. It was working perfectly before I installed the w3all plugin. When I had problems getting the w3all plugin to work, as explained in my previous post, I deactivated the recaptcha plugin. After I got the settings right for the w3all plugin, I reactivated the recaptcha plugin. The recaptcha did not appear on the registration form, but registrations were rejected with an error message that the Google recaptcha had failed. I deactivated the w3all plugin: no change. I deleted the w3all plugin: no change. The deletion process may not have run all the way through; it displayed the "Deleting" message for a long time until I refreshed the page.

Looks like the two plugins are not compatible. How do I revert back to the way things were before installing the w3all plugin?

Thanks,
John

User avatar
axew3
w3all User
w3all User
Posts: 2568
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Recaptcha stopped working

Post by axew3 »

Look here:
viewtopic.php?t=679

I just tested the Advanced Google reCAPTCHA plugin into my localhost and it worked fine

jls
Posts: 4
Joined: Wed Nov 23, 2022 8:50 pm

Re: Recaptcha stopped working

Post by jls »

I figured it out. The problem was not your plugin.

My site is hosted at Site Ground, and they have several plugins to support WP installations. There was an update in the past few days to their SG Optimizer plugin. The problem area was JS minification. I excluded the recaptcha plugin from JS minification, and the problem is gone.

Sorry for your trouble.

Thank you once again!
John

Post Reply