Widget links do not work after full integration

nikola
Posts: 3
Joined: Tue Mar 15, 2022 9:02 am

Widget links do not work after full integration

Post by nikola »

I am setting up integration WP <-> phpBB.

Wordpress is installed in root (w ww.mysite.com)
phpBB is installed in subdomain (forum.mysite.com)

1. User synchronization - works perfectly
2. Widget in WordPress footer showing latest posts on phpBB - works perfectly
3. Performed steps from following page: https://www.axew3.com/w3/2020/01/phpbb- ... iframe-v5/

Now, forum is nicely integrated into WordPress page. All links for phpBB are no longer forum.mysite.com/viewtopic.php...,
now they are w ww.mysite.com/forum/?w3=...

Everything works as expected, only now I have problem with my links in footer.

Case 1 (correct): I am on my WordPress homepage (www.mysite.com) and any link in footer widget take me to corresponding topic on forum.
Case 2 (correct): When I am browsing forum, all links from inside forum works propery
Case 3 (incorrect): When I am using forum and click on link in footer widget, I am not redirected to topic from the link, but instead I stay on same place on forum (link does not take me anywhere)

In Case 3, when I press same link from footer widget several times, actual link is "growing", like this:
.../viewtopic.php?f=28&t=24&p=66#p66
.../viewtopic.php?f=28&t=24&p=66#p66/viewtopic.php?f=28&t=24&p=66#p66
.../viewtopic.php?f=28&t=24&p=66#p66/viewtopic.php?f=28&t=24&p=66#p66/viewtopic.php?f=28&t=24&p=66#p66

Can this be fixed? Did I make some mistake during integration?

User avatar
axew3
w3all User
w3all User
Posts: 2497
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Widget links do not work after full integration

Post by axew3 »

All links for phpBB are no longer forum.mysite.com/viewtopic.php...,
now they are w ww.mysite.com/forum/?w3=...
Widgets and shortcodes links, need to point to the real phpBB URL, so, what link you have put into plugin admin where URL setting?

http://forum.mysite.com

??

nikola
Posts: 3
Joined: Tue Mar 15, 2022 9:02 am

Re: Widget links do not work after full integration

Post by nikola »

Hi, I left real url in plugin settings:
path.png
path.png (36.62 KiB) Viewed 136 times
I prefer not to show real site domain as the site is still under construction, but if really needed, I can give you this info also.

This is how my /forum page looks like:
forum page.png
forum page.png (35.08 KiB) Viewed 136 times
First time I click a link in footer, it works normally.
Link in footer.png
Link in footer.png (49.1 KiB) Viewed 136 times

nikola
Posts: 3
Joined: Tue Mar 15, 2022 9:02 am

Re: Widget links do not work after full integration

Post by nikola »

Now URL in browser looks like this:
Link after klick.png
Link after klick.png (120.42 KiB) Viewed 136 times
And in footer, link is like this, and it doesn't work anymore.
Link in footer 2.png
Link in footer 2.png (52.59 KiB) Viewed 136 times

User avatar
axew3
w3all User
w3all User
Posts: 2497
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Widget links do not work after full integration

Post by axew3 »

Because you are into page forum.
And applied the overall_footer.html js code (note that w3 can be changed into what you more like)
It is exactly as it is here in this example.
It seem all correct, so, where is the problem because seem that i have not understand the issue :?

Do you have any issue by clicking into any link?
It is a way to rewrite real url as base64: it do not interfere with bots/crawlers, that will follow to see only real phpBB urls.

If not applied the overall_header.html code, or as explained on help you comment the reload js instruction, when you'll visits phpBB via direct url, you'll not so being redirected to page-forum (and phpBB not iframed, but at real url, will display/load)

https://www.axew3.com/w3/2020/01/phpbb- ... iframe-v5/

Post Reply