Newbie needing help

JohnDunningUK
Posts: 3
Joined: Wed Jun 26, 2019 2:13 pm

Newbie needing help

Post by JohnDunningUK » Wed Jun 26, 2019 2:26 pm

Hi,
I've been using Wordpress for years now, and have just decided to make use of a forum. I really like the phpBB forum, and thought the bridge plugin you provide looks perfect for my needs. Quite simply I just wanted it so that when someone registers on either the WP site or the forum site, the opposing site duplicates the user and login information too.

To cut a long story short, I've tried to follow all the information on the plugin set up page, but although it seems that everything is in place, nothing has linked up (or at least that I can see). Is it possible that someone here may be able to have a quick look at my set up to see what's wrong please? Or give me some advice how to get things up and running?

Many thanks,

John Dunning

User avatar
axew3
w3all User
w3all User
Posts: 1627
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Newbie needing help

Post by axew3 » Wed Jun 26, 2019 6:53 pm

Hello John!
The RED warning still display on plugin admin page?
If yes, the path to a valid phpBB config.php file mean that it is wrong.
If not, it is strange.

Also:
consider that if an user register in phpBB, then it is added into wordpress when the same user visits as logged in the WP side, but there are several workaround for this if you want the user added in WP at same time also.
If register in WP, it is added at same time in phpBB instead.

But one step per time:
the red warning notice on plugin admin page that say the path to config.php is needed, still display or not?

JohnDunningUK
Posts: 3
Joined: Wed Jun 26, 2019 2:13 pm

Re: Newbie needing help

Post by JohnDunningUK » Wed Jun 26, 2019 7:35 pm

Hi.

Yes I've tried setting the path to the config.php file in the phpbb folder, and also to a custom file as shown, but remains red either way.

I checked the absolute path with my hosting provider, and it seems to be correct.

User avatar
axew3
w3all User
w3all User
Posts: 1627
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Newbie needing help

Post by axew3 » Wed Jun 26, 2019 7:39 pm

you use custom or linking the root phpBB config.php?
If using root phpBB config.php and the red warning still display, then the path isn't correct.
If using the custom config.php, that is the more correct way to avoid incompatibility with some other plugin, after you added all values as needed into it, check also that you
REMOVED UNcommented the very last line (read inline hints into the same file when you open with text editor):
did you changed the last line

Code: Select all

// @define('PHPBB_INSTALLED', true);
into this:

Code: Select all

@define('PHPBB_INSTALLED', true);
substantially remove prepending //

JohnDunningUK
Posts: 3
Joined: Wed Jun 26, 2019 2:13 pm

Re: Newbie needing help

Post by JohnDunningUK » Wed Jun 26, 2019 9:57 pm

Hi,

Thanks again, but I've tried everything, checked it and checked it again, but no joy. Oh well, I'll just have to make do with a plugin like WPForo or something rather than phpBB. Can't say I didn't try.

Kind regards,

John

User avatar
axew3
w3all User
w3all User
Posts: 1627
Joined: Fri Jan 22, 2016 5:15 pm
Location: Italy
Contact:

Re: Newbie needing help

Post by axew3 » Thu Jun 27, 2019 11:20 am

Path setting should not be a problem but in your case seem that you was not able to set it up.
The installation of the plugin is very easy following instructions and reading all hints about, by the way, if you do not want to loose your time setting up things that you are not comfortable with, yes, try to setup something easier then.

Whenever you like to return over this, let know:

URL of your wordpress
absolute path of your server (the path your server indicate that it is the absolute root path)

then i can say you what is the correct path you need to setup.
Cheers!

Post Reply